Control issues with ET-312B


#1

Hello.

I ran into an issue with controlling my ET-312B v1.6 via the websocket server.

I started with the tutorial: https://buttplug.world/tutorial/
Running Windows 10 v1709 build 16299.248
I ran the installer and started the websocket server.
The websocket server, the browser and the ET-312B are all on the same machine.
The websocket listens to the default local wss://localhost:12345/buttplug
Trying to connect from the tutorial, i encountered the first issue.
{DTG}|ERROR|WebsocketServerControl|vtortola.WebSockets-WebSocketException: Not GET request
However, It did connect, from what the Websocket Server Main Window tells me. (Connected) Twine Buttplug Client
I can scan for devices, in the next step, and it does find my ET-312B, connected via FTDI USB2Serial on COM1.
It changes the display of the ET-312B to show it’s controlled by Buttplug too.
If i try to issue any controls through Buttplug, it does nothing on the ET-312B.
None of the values on the display change, the channel lights don’t even twitch, and there is no output produced.

I did try this with the sweep of the tutorial, i did try this with the playground, it just does nothing on the ET-312B, despite properly connecting to it to change the display to the [A00 B00 Buttplug] line.

Another issue i found, After a random time it seems to disconnect from the websocket server.
So assuming this to be an issue with the secure connection, i disabled SSL/TSL on the websicket server, and connected via ws.//localhost:12345/buttplug
Now it stays connected, but i still can’t control the values displayed on the ET-312B.

Is there anything i might have been overlooked? If so, a pointer towards a possible solution would be greatly valued.

Thanks in advance.


#2

Hi!

What kind of messages are you sending? The ET-312 support is still rather limited at this stage - for now, it only responds to fleshlight launch specific commands. We have not defined generic E-Stim messages - yet. This is definitely planned, but for now the initial implementation only emulates a fleshlight launch.

(The motivation behind this is that there is plenty of FL Launch encoded content out there, and we wanted the ET312 module to be useful from the start.)

Have you tried using it through, e.g. Funscript Player? Does that work?


#3

Hello.

Using the Websock Server and https://buttplug.world/playground/, connecting and scanning works fine.

It quickly finds the ET-312B and changes it’s display to [A00 B00 Buttplug].

Clicking the Button [Start Oscillation] on the Playground, the message sent to the ET-312B seems to be

[{“FleshlightLaunchFW12Cmd”:{“Id”:93,“DeviceIndex”:1,“Speed”:50,“Position”:90}}]

This is the kind of log it creates in the Websock Server on loglevel “Trace”.

Yet it does zilch on the ET-312B.

I briefly tried the Funscript Player, but it does the same: Create command entries in the Websock Server log, yet doing nothing on the ET-312B.

I assume the Playground should work with the ET-312B, and this has been tested before release, so the issue has to be on my end.

Yet i still fail to find a clue on what might causing it.


#4

Hmm. So the LEDs don’t light up or anything?

I’m pretty sure both the tutorial and playground should work too, but I’ll check again here in a bit just to make sure. One of the problems with the 312 is that the only way we have to tell signal is by either seeing the LEDs change, or feeling it change. :expressionless:


#5

I get no change in the levels on the display, which only react to the level knobs on the frontpanel, so i assume that’s intended.
I get no blinkenlights on the frontpanel.
I get no current from the outputs.
Up to the websock server, all seems normal, but the ET-312B just shows no sign of response.