Did I recieve a broken Launch?


I just received my Launch a couple of days ago and was very excited to try it out. Got it out of the box, in hope that it would have some charge on it so that I could at least see how it worked.

Pressed the power button to no effect. Figured it arrived with little/no charge, and that it needed a minimum amount of charge to start.

Put to charging, tried turning it on about every hour or so, nothing. The red charging light has been on.

9 hours after getting it out of the box, the charging light changed to green. I tried turning it on again, still nothing.

There seems to be no response what so ever to pressing the power button. The button feels like one would expect from the plastic tab type button when pressed, so I don’t think it’s mechanically broken.

Is my unit defective, or is there some sort of trick to the power-button rather than, you know, pressing and holding it?

Another worrying thing is that I keep getting an error when registering the warranty on the website “Invalid Authenticity code”.

I bought it from a 3rd party retailer. I have contacted them and Kiiroo but I’m still waiting for a response. I hope I can still get a new one, even if I can’t register the warranty

Can you guys help me with this?


When you’ve tried turning it on, is it unplugged from power? Launch’s don’t turn on while charging.


I’ve tried both, pretty much been fiddling with the thing quite a lot, applying different kinds of pressure etc, the button just doesn’t do anything.

I took a short video of me unplugging the charger (to show that the light works), and trying to press the button. Sent it with my support request to Kiiroo. But like I said, I’m not sure they’ll want to help when I can’t even register it with the code on my box. (I’ve tried several times, always end up with the same error).

I sort of suspect that the retailer sent me a unit they’re gotten in return from another customer or something, and that’s how it was broken. The seals on the box were intact when I got it though.


Sounds like something is broken, yeah. Definitely haven’t had any issues turning on any of the Launches I’ve tried.



I recently had more or less the exact same thing happen to me, I sent a video to fleshlight customer service and they said they would send it to kiiroo for a solution with no response yet after about 2 weeks.

My problem is sometimes it works perfectly, that is, it charges when I plug it in, and turns on when I press the power button.

But then randomly sometimes it won’t work for days, it won’t charge when it’s plugged in, and won’t turn on.

Would love to find a solution.