ERROR UWPBluetoothDeviceFactory Found 0 services for Fuse, which is more/less than 1. Please fix this in the bluetooth definition


#1

I’ve noticed with a couple different computers with built-in bluetooth that this happens when scanning for devices.

ERROR|UWPBluetoothDeviceFactory|Found 0 services for Fuse, which is more/less than 1. Please fix this in the bluetooth definition.

Any way I can get around this without having to get a dongle?

The bluetooth adapter is from intel using drivers provided by Microsoft.


#2

Does the same Fuse show up as working on other devices?


#3

Yep. That and the Kiiroo launch. The launch produces the same error.

I have a bluetooth dongle and things work fine with that. We’re creating a unity project and we’re trying to do what we can to make it easy for others.


#4

Ok, thanks for the update! We’ll try to take a look, though that will require finding machines with a built-in Intel chip.

It sounds like the devices are seen but are not responding to service queries, which seems a little odd.

If you don’t mind me asking, what version of Unity are you working with?


#5

Using 2017.3.0p3

This works fine when I use the Asus bluetooth adapter that I have, even in our Unity project.


#6

I’m happy to test remotely any way that I can. My laptops and desktops all seem to have the same chipset.


#7

I get the same error with a Qualcomm Atheros AR3012 Bluetooth 4.0 device (in my laptop)


#8

Can you run “winver” and tell me what OS Build number you’re on?


#9

Windows 10
Version 1803 (OS Build 17134.165)

This machine worked with buttplug when using a USB bluetooth device. Just not with internal.


#10

Ok, cool, just wanted to make sure we’re on the same builds. Working on hunting down one of the chipsets you’ve mentioned to test locally, will let you know.


#11

Hey, quick update. The intel chip had NO problems with the Lovense Max connecting and sending commands. Works great. Starting to think its an issue with Kiiroo devices.


#12

Well huh. That is certainly odd. Do you have any of the newer Lovense toys handy?


#13

Nope. Just got this one today. Big project underway but budget is limited.


#14

'k, no prob. The Nora and Max were Lovense’s first products, and used a dual-band BT Classic/LE chip. I think everything else uses a BLE only chip now and I’m not sure if they ever changed the Max circuit board, which is why I ask.

What name does the Max show up as? LVS-B001 or something?


#15

LVS_B017 specifically