Fleshlight Launch Blue tooth red blinking


#1

I just bought the new Fleshlight launch today and used it one time worked great. But when I went to use it a 2nd time only it stopped midway into the session and a red light where the usual blue light is goes off. It’s been 1 hour since then and now it’s not working it turns off and on but remains doing the same thing with no movement. There is nothing obstructing it and I can move the sleeve up and down fine but it’s just not working. Has anyone had this issue before and if so how can I solve it.


#2

I recall if you get a blinking red light it’s usually associated with a motor issue. Have you tried moving the motor up and down while the device is turned on (then turning it off/on)?


#3

I have and still nothing.


#4

Sounds like you might need to take it apart and check if motor parts are greased properly?


#5

Red blinking light when it turns on means it can’t home. There’s a little hall effect sensor on the circuit board, and a magnet on the Fleshlight Holder. Whenever you turn the Launch on, the holdy-bit (technical term :stuck_out_tongue:) slides down 'til that magnet lines up. If it can’t line up within a certain amount of time, you get the blinky red light.

Usually, this means that something is stuck, or possibly that the motor stopped working. Your best bet may be to get in touch with Kiiroo customer support, as I’ve seen them have to replace multiple Launches due to this over on r/fleshlight on reddit. They may ask you to take a video of it not working and send it to them.

Once you get that done, if you’re still interested in trying repair, we might be able to fix it for you here. Then you can have /2/ launches!


#6

I small rectangle magnet came out of mine , is there a magnet under the spinning disk ontop the motor ?

After this happened , i got the red light
Want to put the magnet back


#7

The magnet is what lets the motor know when to stop. There’s a little magnet sensor on the circuit board. However, seems that in some Launch devices, that magnet isn’t glued in very well. So, you’ve got two options.

First thing you could do is report this to Kiiroo support and have them send you a new one, which is totally within your right. The thing fell apart, it’s not your fault, it should be covered under warrenty. Then you can try fixing your old one without worrying about ruining it completely.

Otherwise, yeah, you can try to get the launch apart to fix it, but I’ll have to check some of my pictures to remember where the magnet goes and get back to you on that.


#8

Yeah if you could take a picture of the magnet position at all the way down that would be great !!! I just need to see orientation of it

Seems like such a simple fix im not worried, but yeah need a refence photo .

But even if i brick it, a nema 17 fits perfect :slight_smile:


#9

Nvm replacement is in the mail, waiting on the coupler and im going to put a nema in it , also a better encoder


#10

Awesome! Lemme know how your mods go. Honestly would love to just completely rewrite the firmware so we could get better control, parametric commands, etc, but it’s gonna require writing tools first. :frowning:


#11

Hi. I also have had the issue with the magnet. I called the company I bought it from and they said to send them a video of it not working, ie red blinking light and they sent me a new one immediately. As I still have the faulty one I am interested in knowing where to glue the magnet to??. They are easy to pull apart so would hope to fix it. Any idea metafetish?


#12

Ok, I’m starting to see this question all over the place. Luckily I still have my filming equipment set up as I’m working on a new Buttpluggin’ with qDot video right now, so I’ll try to put something together to show how magnet replacement works.


#13

I ran into this same issue. It was the magnet that had come loose. I just fixed mine, but I figured I try and save some people frustration with the disassembly process. Mainly the last piece to remove. This video will get you most of the way there https://youtu.be/sA7MdO0rEoo?t=1829. The final step would be to separate the “inner shell”. The “top” (piece the circuit board is attached to) piece slides away from where the rubber would be. For me it took quite a bit of force (rubber mallet) to get the piece to move. Once you have that off, replacing the magnet is very simple. You don’t need to worry about the magnet placement, there is an indent in the piece the fleshlight attaches to. I put just a dab of super glue in to ensure the magnet never falls out again.

Hopefully that helps anyone considering taking their launch apart.


#14

Thanks for adding this! We just had someone with the same problem on discord server, will be good to be able to point them to this post. :slight_smile:


#15

Thanks qdot for the dissassembly video. Would have never figued out how to open it without it.
And thanks JustAnotherDude for the rest of the guide. Managed to glue the magnet back and now my launch works again.