Fleshlight Launch bluetooth connection help


#1

I have a Fleshlight Launch that I was able to connect to my PC via bluetooth one time… but now it no longer shows up on multiple (3) different PCs / bluetooth adapters and doesn’t show up on my Android phone either via the Feel Connect app. Anyone know if this is a known issue that can be worked around? It was working for a few hours, then the next day I was having issues so I disconnected the bluetooth connection and could not reconnect. I’ve literally had it flashing blue for hours attempting to connect. Is there a firmware reset mechanism?

I have a kiiroo support ticket open, but have yet to receive a response. I figure’d this forum might actually be a better place to get support.

Thanks


#2

Still waiting on my Launch to arrive so probably can’t help. Guessing you have already looked at the Launch problems flowchart on the kiiroo website but if not it might be of help to you or others who stumble on this post.


#3

Yeah, I’ve been to that chart and tried restarting all machines and the device many many times. I’m wondering if by connecting it to the PC first to mess around caused a problem instead of letting it check for a firmware update on the Feel Connect app first.


#4

Hmm. What kind of phone and PC are you trying to connect to? And it’s always blinking blue, never actually going solid blue, right? Also, do you happen to have a macOS machine handy?


#5

Hey, thanks for the reply. You are a gentleman and a scholar by the way.

Yes, blinking blue. Phone is a Note 4. I’ve tried 3 different Windows 10 machines. The machine that connected the one time has this bluetooth USB dongle: https://www.amazon.com/gp/product/B00T9NP7QQ

Another machine has a Cambridge Silicon Radio of some sort, and I have a Zotac Zbox (https://www.amazon.com/ZOTAC-dual-core-Processor-Bluetooth-ZBOX-EN760-U/dp/B00KX8OX2K) with an intel bluetooth of some sort. I’m not sure the best process to identify the chipset exactly.

Windows update says drivers are up to date. All of these machines connect fine to other bluetooth devices.

I do not have a mac handy sadly.


#6

Ok, well, I know this should work with a CSR at least, not sure what kind of chip is in the coocheer.

So, kinda stabbing in the dark here, but… On your note 4, if you’re cool doing some experimentation, try downloading this app: https://play.google.com/store/apps/details?id=no.nordicsemi.android.mcp&hl=en

With the launch on and blue light blinking, try scanning in that app and see if the device comes up. If it does, we can continue checking things from there.


#7

I don’t see anything that says “launch” when scanning with the nRF app. I see a ton of “N/A” devices however and some other devices I recognize. Most of the “N/A” devices have apple logos.


#8

Ok, that’s weird. With the phone scanning and the launch blinking, you should see a launch. Just curious, does the launch still work in manual mode?


#9

Yep, still works in manual mode fine. I don’t think there’s any chance of liquid damage… I’ve only had it a couple days and was pretty careful with it. It was connected via bluetooth and seemed to be working when I disconnected it… and I haven’t used it since it failed to reconnect. I’m a bit stumped. I’d like to try some sort of firmware reset but can’t find any documentation on that.

Maybe I should run out the battery completely.


#10

Did you upgrade your firmware on first connect to feelconnect?


#11

I was never able to connect to Feel Connect. The first thing I did was connect to my PC and play around with ScriptPlayer. As a developer, I had no intention of ever using the phone. Once I disconnected it from my PC, I could no longer connect anywhere (which is when I started trying to use the phone to sanity check).


#12

Well huh. One of the unwritten rules of Buttplug/ScriptPlayer is that we expect you to have the 1.2 Firmware, which currently can only be loaded by the FeelConnect app, so that would’ve been required. We have enough information to write our own firmware loader but that’s gonna take some time. I don’t see /why/ there should be a connection problem, even if you’re on 1.1 firmware though. Obviously the device is booting and running the firmware since it just blinks blue.

I suppose it could be that with the 1.1 firmware, it may also not show up as “Launch”? We’ve had people manage to use Buttplug/ScriptPlayer with a 1.0/1.1 firmware Launch though. So, continuing to stab in the dark: The Launch should still use the same services, so on the nordic radios app, if you look through the devices with no name and see one with a service GUID of

88f80580-0000-01e6-aace-0002a5d5c51b

that’s the Launch, in which case maybe it just doesn’t have a name for some reason.


#13

Hmm… all devices I can see in the area are either apple devices or are a specific known device. I don’t see that GUID. I remember that when I did connect it the one time, it did show up as “Launch” in Windows when I added the bluetooth device.


#14

Ok, well, in that case, maybe something is actually up with the radio itself? I’m not really sure how to diagnose that from afar. At this point I’m just hoping customer service gets back to you. :confused:


#15

Alright… thanks for taking a crack at it.


#16

Ok, circling back to this because I just helped someone else debug this on a PC with a CSR dongle. On those windows machines, did you have to install any software to get the dongles working?


#17

How did this one play out for you? I have:

  • Gone through the steps in the Launch Problems Flowchart
  • Deleted the Feel Connect app
  • Restarted the iPhone
  • Re-installed the app
  • Restarted the Launch
  • Jiggled bluetooth on and off for the Launch and the iPhone.
  • Downloaded a bluetooth scanner app and I can’t even see the Launch in that, nor the the Feel Connect app, nor my Win. 10 machine with all the latest updates

Have I reached my limit on what I can try? I keep hoping I’ll come across some sort of Launch master reset combo-button-hold-on-restart type thing that will slap it back to attention.


#18

Wow, ok, hadn’t heard about failures on iPhone yet, it’s always been pretty solid there for me.

So first off, what platforms do you have? It looks like iPhone and Windows 10? Happen to have a macbook around too?


#19

I ended up having a problem with manual mode as well, and they ended up sending me a new one after I sent them a video showing both problems. They ignored my queries about a reset command so I can only suppose one does not exist. I’ve had some success with bluetooth quirks on devices in the past by removing batteries forcefully or draining batteries. I did try to train the battery on the first one but it didn’t seem to help, and since it’s likely a LiPo, it probably doesn’t actually “drain” in the normal sense.


#20

Wow, crazy. Yeah, there’s no “reset” command because if firmware loading fails, there’s no firmware on the chip to reset to. That’s why I built my own firmware loader, because we can at least see which step is going wrong and concentrate on fixing that.

I can’t see why you have to remove/drain batteries for bluetooth weirdness. In my experience, it’s usually on the phone side of things.