Fleshlight Launch bluetooth connection help


#10

Did you upgrade your firmware on first connect to feelconnect?


#11

I was never able to connect to Feel Connect. The first thing I did was connect to my PC and play around with ScriptPlayer. As a developer, I had no intention of ever using the phone. Once I disconnected it from my PC, I could no longer connect anywhere (which is when I started trying to use the phone to sanity check).


#12

Well huh. One of the unwritten rules of Buttplug/ScriptPlayer is that we expect you to have the 1.2 Firmware, which currently can only be loaded by the FeelConnect app, so that would’ve been required. We have enough information to write our own firmware loader but that’s gonna take some time. I don’t see /why/ there should be a connection problem, even if you’re on 1.1 firmware though. Obviously the device is booting and running the firmware since it just blinks blue.

I suppose it could be that with the 1.1 firmware, it may also not show up as “Launch”? We’ve had people manage to use Buttplug/ScriptPlayer with a 1.0/1.1 firmware Launch though. So, continuing to stab in the dark: The Launch should still use the same services, so on the nordic radios app, if you look through the devices with no name and see one with a service GUID of

88f80580-0000-01e6-aace-0002a5d5c51b

that’s the Launch, in which case maybe it just doesn’t have a name for some reason.


#13

Hmm… all devices I can see in the area are either apple devices or are a specific known device. I don’t see that GUID. I remember that when I did connect it the one time, it did show up as “Launch” in Windows when I added the bluetooth device.


#14

Ok, well, in that case, maybe something is actually up with the radio itself? I’m not really sure how to diagnose that from afar. At this point I’m just hoping customer service gets back to you. :confused:


#15

Alright… thanks for taking a crack at it.


#16

Ok, circling back to this because I just helped someone else debug this on a PC with a CSR dongle. On those windows machines, did you have to install any software to get the dongles working?


#17

How did this one play out for you? I have:

  • Gone through the steps in the Launch Problems Flowchart
  • Deleted the Feel Connect app
  • Restarted the iPhone
  • Re-installed the app
  • Restarted the Launch
  • Jiggled bluetooth on and off for the Launch and the iPhone.
  • Downloaded a bluetooth scanner app and I can’t even see the Launch in that, nor the the Feel Connect app, nor my Win. 10 machine with all the latest updates

Have I reached my limit on what I can try? I keep hoping I’ll come across some sort of Launch master reset combo-button-hold-on-restart type thing that will slap it back to attention.


#18

Wow, ok, hadn’t heard about failures on iPhone yet, it’s always been pretty solid there for me.

So first off, what platforms do you have? It looks like iPhone and Windows 10? Happen to have a macbook around too?


#19

I ended up having a problem with manual mode as well, and they ended up sending me a new one after I sent them a video showing both problems. They ignored my queries about a reset command so I can only suppose one does not exist. I’ve had some success with bluetooth quirks on devices in the past by removing batteries forcefully or draining batteries. I did try to train the battery on the first one but it didn’t seem to help, and since it’s likely a LiPo, it probably doesn’t actually “drain” in the normal sense.


#20

Wow, crazy. Yeah, there’s no “reset” command because if firmware loading fails, there’s no firmware on the chip to reset to. That’s why I built my own firmware loader, because we can at least see which step is going wrong and concentrate on fixing that.

I can’t see why you have to remove/drain batteries for bluetooth weirdness. In my experience, it’s usually on the phone side of things.


#21

I’m now having problems connecting with my windows machine too. It shows, connects momentarily and then just starts blinking. Still connects with the app on android though. firmware is 1.3. Any ideas?


#22

This is with 2 different dongles btw


#23

What program are you using to connect on your windows machine?


#24

Following up on this—ended up contacting customer service and sent them a video documenting my problem. The honored the warranty and sent a replacement. So now I’m all set to check out the Win 10 scripts. Thanks for your assistance and work in this area.


#25

Great! Just let us know if you have any other problems or questions.


#26

Hey guys,
Sorry to revive this, but seems like the appropriate place to post instead of starting a new thread.

Recently received my Launch and have been trying to get to connect with the PC (Win 10). It connects very intermittently, but most of the time the Buttplug Server logs are just regurgitating this:

2019-02-17 11:11:59.0326|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:32.8308|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:58.9836|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:11:58.9836|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:53.1646|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:53.1186|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:12:22.1653|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:12:22.1123|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:12:22.1123|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:53.1186|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:11:32.8838|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:32.8308|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory

Not sure what that means though, sorry!

Seems to consistently connect to my android, and my android can consistently see my PC (and vice versa) but the Launch just drops in and out of the PC or sits blinking for ages. Only tried the one dongle so far, so it might be that?
Onvian-Dongle-Receiver-Transfer-Wireless-Bluetooth-Adapter-Usb-Csr-4-0-New

Any help is obviously appreciated. :slight_smile: Cheers!!


#27

same happened to me today… it was working less than 2 months… feel connect and scriptplayer not finding my device, it was running on firmware that came with device, I was never asked to update it in feel connect etc. Is there any way I can solve this? any firmware loader or maybe reset to fix this?


#28

Okay so I have tried everything listed and have been unable to get the Launch to connect to anything. Unfortunately I bought my Launch back in 2017 and didnt really start using it until recently so my warranty is shot. My problem is nearly identical to the original poster. Blue light blinks but no connection. I have tried two different phones and computers. I got the recommended usb Bluetooth device and I downloaded a scanner. seems like the launch is not sending out any signals.
Thoughts or am I just screwed?


#29

I’m on my second launch giving me exactly the same problem. After a few weeks of use, the bluetooth radio just fails to show up on any device. The first one I could return, but the second one I can’t after using it for 3 months. I tried contacting Fleshlight, but their customer support wasn’t too helpful with technical questions.

I don’t think I’ll buy a 3rd one. :cry:

I sure hope Kiiroo comes up with a more robust Launch v2.0 out soon.