Fleshlight Launch bluetooth connection help

I’m now having problems connecting with my windows machine too. It shows, connects momentarily and then just starts blinking. Still connects with the app on android though. firmware is 1.3. Any ideas?

This is with 2 different dongles btw

What program are you using to connect on your windows machine?

Following up on this—ended up contacting customer service and sent them a video documenting my problem. The honored the warranty and sent a replacement. So now I’m all set to check out the Win 10 scripts. Thanks for your assistance and work in this area.

Great! Just let us know if you have any other problems or questions.

Hey guys,
Sorry to revive this, but seems like the appropriate place to post instead of starting a new thread.

Recently received my Launch and have been trying to get to connect with the PC (Win 10). It connects very intermittently, but most of the time the Buttplug Server logs are just regurgitating this:

2019-02-17 11:11:59.0326|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:32.8308|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:58.9836|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:11:58.9836|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:53.1646|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:53.1186|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:12:22.1653|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:12:22.1123|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:12:22.1123|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2019-02-17 11:11:53.1186|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2019-02-17 11:11:32.8838|ERROR|UWPBluetoothDeviceFactory|Found 0 services for Launch, which is more/less than 1. Please fix this in the bluetooth definition.
2019-02-17 11:11:32.8308|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory

Not sure what that means though, sorry!

Seems to consistently connect to my android, and my android can consistently see my PC (and vice versa) but the Launch just drops in and out of the PC or sits blinking for ages. Only tried the one dongle so far, so it might be that?
Onvian-Dongle-Receiver-Transfer-Wireless-Bluetooth-Adapter-Usb-Csr-4-0-New

Any help is obviously appreciated. :slight_smile: Cheers!!

same happened to me today… it was working less than 2 months… feel connect and scriptplayer not finding my device, it was running on firmware that came with device, I was never asked to update it in feel connect etc. Is there any way I can solve this? any firmware loader or maybe reset to fix this?

1 Like

Okay so I have tried everything listed and have been unable to get the Launch to connect to anything. Unfortunately I bought my Launch back in 2017 and didnt really start using it until recently so my warranty is shot. My problem is nearly identical to the original poster. Blue light blinks but no connection. I have tried two different phones and computers. I got the recommended usb Bluetooth device and I downloaded a scanner. seems like the launch is not sending out any signals.
Thoughts or am I just screwed?

I’m on my second launch giving me exactly the same problem. After a few weeks of use, the bluetooth radio just fails to show up on any device. The first one I could return, but the second one I can’t after using it for 3 months. I tried contacting Fleshlight, but their customer support wasn’t too helpful with technical questions.

I don’t think I’ll buy a 3rd one. :cry:

I sure hope Kiiroo comes up with a more robust Launch v2.0 out soon.

I had the exact same issue with my Launch I purchased on august 2018. Lucky enough there is 3 weeks remaining on my warranty. I send them an email with a video attached showing the blinking blue light next to my IPhone. It showed them that the Launch will not connect to bluetooth.

They replied saying they were sending a replaement right away. After many researches over the net, it seems that the bluetooth radio is not transmitting anymore.

I wonder if there is a way to replace the Bluetooth chip to solve the issue or maybe a way to reprogram the unit to reset the bluetooth radio.

Hope someone has an idea to get that bluetooth radio transmitting again !

Ben.

Is this the Fleshlight Launch you’re having issues with: https://www.mysextoyguide.com/fleshlight-launch-review/

I been thinking to buy it but now have some quality concerns after reading about issues folks have with it :confused:

Yup, that’s it. Quality is an issue, but the support turnaround is usually pretty fast and there’s not much better out there right now.

Hi. I have a Lenovo T420, 2.7Ghz proc w/8Gig RAM running Windows 10 build 18362.295 and I’m trying to connect a Fleshlight Launch to it.

I have installed Intiface Desktop version 16.0.0. With Bluetooth active on both the laptop and Launch, I received “Server executable install location C:\Program Files (x86)\IntifaceCLI does not exist.” upon server start. I located IntifaceCLI in a previously downloaded (not installed) buttplug C# (0.5.0) and copied it to Program Files (x86).

I restarted the server only to receive “Server executable install location C:\Program Files (x86)\IntifaceCLI\IntifaceCLI.exe does not exist.” I am unable to locate it.

Where might I find the executable and should I anticipate anymore challenges?

Last question (and this probably for Fleshlight and/or KIIROo); is plug and play a future possibility? Thank you for your kind response.

Huh, that’s odd. It sounds like the Intiface CLI installer didn’t actually… install?

Try downloading this and installing it (which is what intiface does when it updates, I need to have add a “force reinstall” option): https://github.com/intiface/intiface-cli-csharp/releases/download/0.5.0.0/intiface-cli-csharp-win-x64-Release-0.5.0.0-installer.exe

Also, what’s your definition of Plug and Play?

Thank you for your quick response, q. So I need to enter “intiface-cli-csharp-win-x64-Release-0.5.0.0-installer force install” on a command line? (I might just rename the exe file, if this is what you mean - less cumbersome.)

Re plug and play:
When I physically plug in a new device into a Mac or PC, the OS recognizes it as such, looks for the drivers, installs if found and then connects the said device. I assume when one connects wirelessly (Bluetooth), the process would be much the same only wirelessly. (I can’t think of any device/machine interface that does it but why not?)

Failing that, why isn’t the Launch recognized when it is plugged in to a computer (ie., when charging). Does the Launch just not have the smarts?

Thanks again.

Oh, sorry. I meant just download the file and run it. You shouldn’t need to do anything special.

Ignore that “force reinstall” thing, that was me talking to myself.

We could possibly have toys pair with the operating system, but no one has really requested that yet, and it can get a bit confusing. It’s something I’ll consider though.

Yup, the launch just does not have the smarts. USB is only providing power, Kiiroo opt’d to not include USB control because it’s mean extra chips on the PCB and what not and they’re seriously into cost minimization. Sucks tho, 'cause wired control is nice and reliable.