Getting the Firmware for MK312

After a fight with my hardware to actually get to talk to the ATMega I’ve hit a snag I can’t work around.

scripts/ --downloadfw

Returns error 403: forbidden.
Is there an alternative path?

Unfortunately there isn’t an alternative path right now. The firmware files have been removed from the website. We’re trying to figure out other solutions now.

A few helpful members have sent me the files, so if anyone else finds themselves stuck just ask and you will receive :grin:

Build the box - hurrah
Install the firmware - hurrah
Pass the self-test without the dreaded Error 20/21 - hurrah
Discover you’ve put the f-ing buttons on 90degrees out - booooooooooo

Thankfully the BT works and I managed to use Buttplug to confirm everything is working otherwise.

–> off to de-solder and swear my way through lining up those little buggers a second time

Wow I am rather shocked your BT worked enough to see anything happen. It’s been super flakey for me.

Congrats tho!

It’s connected within about 30secs each time I tried it and stayed connected. Without it I wouldn’t have figured out that my only issues was the buttons. I don’t quite understand what Playground is making it do, but it makes it do things.

Right now, all Buttplug can do is emulate Fleshlight commands, so it will cause intensity to oscillate between 2 points at a certain speed. Hopefully there will be better intensity controls soon.

As as a new user I ain’t allowed to pester you folks via PM: Could someone give me a private 1:1 tutoring regarding the original firmware files?

Edit: Found a tutor, thx again.

By the way, I found some firmware in github repository. I do not know what it is or how much it works. I did not try it.

For myself, I compiled my own with the franconebutt m005. I hope this is the most up-to-date version.

Random thought. Is the firmware dump exploit easily reproducible? We could post a script that downloads (decryption not even necessary) a firmware file from any ET312.

I do not have the ET-312 available. But I’m afraid the processor will be locked against reading memory.

That’s the thing… there is an exploit to achieve just that.

No there isn’t. In the original firmware, there’s a limit to the range of memory that can be peeked, so we can’t just dump it out, and we’d already undone the “encryption” before we starting trying to do things like dynamic code insertion.

I am also stuck with the 403 error. :cry:
Any chance you can forward me the files you received?

Is there an answer as to where to find the firmware? My box is all done save for flashing the firmware. Thanks!

Sorry guys, I hadn’t logged in for ages.

Did other people sort you out with the files already?