Issues with Syncydink

Hello guys. I was super excited to try the Syncydink player with my Fleshlight Launch and an Android phone with Google cardboard-type glasses. But I had a couple of issues.

First, issue with the play of videos. I’ve uploaded three VR videos on my phone, with three funscripts for them. The scripts all worked with the launch, and all videos provided me with sound. But only one video was with image, two others were just black screen. Also, there was no button for VR mode at all. I click VR enable, and nothing happens.

So, the troubles I have are:

  1. Not all VR videos work properly: they all have sound and work with funscripts, but only one shows image, (probably unsupported formats, so what formats are the most preferable? or there can be other reasons for that?)
  2. No VR mode button after the video starts. I click on Enable VR, and nothing really changes there.

I use Chrome browser on Android 10 phone. (Galaxy note 10).
Moreover, I’ve tried to play it from the PC and Mac Chrome browsers - result was the same: no VR mode at all.

Please help me to solve it!)