Launch firmware update problem


#21

Managed to connect using your URL after many tries. But had no idea where the firmware is to be found to I tried using the app again and it crapped out on me in the finalize phase. Do you know where I can find the firmware file?


#22

Used your URL again and after many frustrationg tries, rebooting phone, bluetooth on and off and rebooting device I finally skipped the pairing with the phone and that made this easier. Updated using the app and was going to turn off bluetooth at the stage where the device moves a bit and enters the finalize step but noticed that that happened automatically now and completed successfully.
So dont pair device with your phone directly seems to have made a differance. Thanks a lot for your help


#23

When trying this it finds the launch and I hit pair it start load “Retrieving information from Hardware”, then goes to NetworkError: Connection Failed for Unknown Reason.

Using Google Chrome with an S8.


#24

Oh yeah. Don’t pair the device with your phone or desktop. Due to the way BLE connections work, they need to be unpaired when you try to connect, otherwise weird stuff happens that we can’t detect and things will fail silently. Glad you got things working!

I’ll add a note about that to the firmware loader, just to make sure no one else gets tripped up on that.


#26

Hmm, ok, I haven’t seen that error before. I’ll read up on what that means and let you know what I figure out. Just checking, you don’t have the launch paired with the phone do you (meaning it doesn’t show up in the bluetooth settings on the phone)? If so, it may need to be unpaired.


#27

Ok, I managed to replicate this error by turning the launch off while it was pairing, so I think it may be an issue with it not having enough power or something? Is the Launch fully charged, and did you put your phone near it?


#28

Launch had low battery, phone was near and not paired directly to phone. Once launch is fully charged I will try again and let you know what happens.


#29

Same problem here for recent purchased Launch. Boot mode after failed firmware. Only appears on bluetooth when the Lauch is powered, but gives error. Second try, is missing. In your updater web, first time GATT error, second time connects forever. I turn it off and then on and the same happens.
One time it was able to conect, updated the firmware (with some 1.3 firmware in hex that I found), finished correctly, but then it was in boot mode again.
Thanks for your time.


#30

Ok, great. If firmware loaded, you’re most of the way there.

Go to the firmware update page, do the first “connect” step again where it tries to pull the firmware version. After that, it should present you with a “reboot into normal mode” step. Do that. The Launch should start blinking blue. Don’t touch it at this point, just leave it on and blinking.

Then, with the launch blinking blue, reload the webpage, and do the connect/firmware version step one more time. That should lock it into normal mode.

Let me know if that works for you.


#31

It worked, thanks! After several tries with GATT error, Normal Mode enabled, but firmware version still shows 1.1. I’m not going to try to update it. Again, thank you.


#32

Unfortunately to use almost anything you’re going to need to update to 1.2, so it’s worth it to try getting the 1.3 firmware on there.


#33

Everytime I try, all I can get it to say is “retrieving information from device” with the spinning circle. Ive ran 3 tests the longest being an hour and I cant get past this step. Please help.


#34

Ok. Obviously I need to put some timeouts in 'cause if it’s not working within like, 30 seconds, something is up.

What OS are you trying to flash the firmware on?


#35

Hi qdot, may I ask whereabouts could I get the firmware file?

Also, the error message I had was different to what have been mentioned here (see screenshoot below).


#36

Yeah, current firmware is at

https://feel-technologies.com/firmware/Launch_V1.3.hex

And “Push Block command error” is probably the most common error, just means something failed while sending a chunk of firmware over.

Lemme know if you have issues with the web firmware loader. It can be kinda flakey sometimes too. If you have a mac or linux box around, I recommend running it on google chrome on those, but if all you’ve got is an android, that can work too.


#37

Sweet, web firmware loader works perfectly on my macbook, Launch back to life again! Thank you very much qdot!


#38

Great! Yeah, things work pretty much flawlessly on mac/linux (and hopefully soon windows). Android is hell though.


#39

Hello Qdot,

First of all thanks for putting the webloader up, and I am glad that some people have found it helpful.

I however keep getting stuck on the " Retrieving information from Hardware " step.

Any tips?

Thanks in advance


#40

What operating system/browser are you using?


#41

I am on my Android, Samsung Galaxy s8, and using Chrome