Launch firmware update problem


#42

it worked now and I am on the step where I need to select and upload a Firmware file…how do I proceed?


#43

Oh yeah, still need to add those instructions. -.-

Grab https://feel-technologies.com/firmware/Launch_V1.3.hex and put that file on your phone, then choose it from the firmware selection dialog. That’s the firmware file it needs to upload.


#44

For some reason, I managed to get it back in to normal blue light mode with you web loader. Now it connected to the Feelme app, says version is 1.3 and seems to work.

Gonna have to try and sync it to a video though, will post an update here.

Follow up: Yeah it now seems to work properly, had the web launcher put it out of BOOT MODE and into the blue mode. Then it worked. Thanks alot Qdot for your hard work.

Not all I am waiting for is some update to make it sync better with videos, or am I the only one experiencing lag on videos?


#45

What are you using to play videos?


#46

I was just testing the Pornhub content, and one free Feel me video. Not really sure where to get the best quality videos yet


#47

Ok, so anything going through FeelConnect is gonna be laggy as hell. tl;dr they send all commands through the network and it’s super slow. https://www.youtube.com/watch?v=sA7MdO0rEoo if you want the full rundown on why that happens.

There’s a few options for playing stuff locally, including ScriptPlayer (https://github.com/FredTungsten/ScriptPlayer/wiki), for windows 10, and Syncydink (Tutorial: Syncydink v20170821), which works with Win10/Mac/Linux/Android through the web browser. You can find scripts for movies at the https://realtouchscripts.com forums.


#48

Ah cheers, I will check it out :slight_smile:


#49

hello qdot!
I just received my kiiroo pearl 2 today but have been experiencing issues with start up. I downloaded feel performer app, went through the step to connect the device and the app told me that I needed to update the firmware. I have an android phone. I started the update process and to no avail, the app told me that the update was unsuccessful. I backed out of the app to restart and the vibrator switched to a solid red light. I can turn the vibrator off and on, but the mode is still a solid red light. I tried charging the device for over 2 hours to make sure it wasn’t the battery and the light has not changed. I disconnected device and app, uninstalled and then reinstalled the feel performer app and am currently try to reconnect the device but it’s not working. I have no idea how to go about fixing this issue so i can use my device.

Any ideas what could be happening and how I can fix this?


#50

Ugh. Sounds like the Pearl 2 may have the same firmware loading problems as the Launch.

The good news is, I also have a Pearl 2, so I at least have something to test on, and the firmware loading algo is basically the same.

The bad news is that “basically the same” still means “different”. The Pearl 2/Onyx 2 firmware loading algo is slightly different than the Launch, meaning I’m gonna have to add new code to the firmware loader in order to get it working with the Pearl 2.

If you want stuff fixed /now/, you might try contacting Kiiroo and seeing if they’ll send you another one. I definitely plan on adding Pearl 2 support to the firmware loader at some point, but my project pile is way too big as is right now so I’m not sure when I’ll be able to get to it.


#51

Oh and for anyone else reading this thread, I’ve filed a bug on the Onyx 2/Pearl 2 firmware loading. If you go to this bug page and see that it’s closed, that hopefully means the firmware loader works. :slight_smile:


#52

ok, thanks for looking into this. I have already submitted a request to Kiiroo.

If they send me a new pearl 2, any suggestions on how to avoid this happening again? should I avoid launching the toy with the app until further notice?


#53

So, the problem is mainly that their firmware loading algo isn’t very resilient to failures, and I don’t know why they can’t connect to the toy when it’s stuck in bootloader mode.

This almost always happens with Android phones, so if you can borrow someone’s iphone to upgrade it, that usually works better (the bluetooth is more reliable). Otherwise hopefully I’ll have the web loader fixed up soon and you can just use that and then you’ll hopefully have /2/ working pearls! :slight_smile:


#54

ok great! Thank you so much!

If I can find someone that has an iphone, do I just download the app as normal and it should connect and let me update?


#55

Yup. I’ve never had a firmware error report from anyone with an iphone, it seems to be android phones only, which isn’t much of a surprise since who knows what chip everyone’s android might be running on.


#56

Got it! Thanks, I’ll give that a try and see what happens!

I appreciate the quick response and for helping to resolve this


#57

No prob, happy to help! Hopefully we’ll have Pearl 2 support in Buttplug soon too. :slight_smile:


#58

any good news about pearl 2 support? broke gf’s and someone is a little mad :wink:


#59

Annnnnd a month later…

It’s still on the todo list unfortunately. The firmware loader is kinda brittle and takes a while to test, so I haven’t had a chance to get to it yet. Soon hopefully.