Launch + ScriptPlayer + BT dongle connection issues


#1

Hello- need some assistance please.

My new launch bricked (red/blue flashing lights) after a failed 1.3 f/w update on my pixel / feelConnect app (got stuck on finalizing step at the end). I managed to get the web f/w utility to reflash the launch, now it works as intended with FeelMe etc (I say works as intended, but FeelMe etc is laggy as hell in regards to the Launch’s movements). (TYVM FOR THIS!!!)

Note: my Launch was flashing red / blue, and I could not see or connect to it via bluetooth after the failed f/w update. It wouldn’t connect to anything but my macbook pro, only after I plugged the launch in to charge, and disconnected the power cable - so the power LED was solid green and no blue or red lights. Only then would it connect to the utility, and flash. Took a while to figure that out, so I thought I’d post that up for others.

So then I started looking for an offline solution, to hopefully get the launch to sync to the video better. Downloaded script player 1.0.5, grabbed a few scripts and videos to test.

I cannot “connect launch directly” - I click it, but nothing happens - and the launch continues to blink blue, searching for a connection. Thinking the bluetooth dongle I purchased wasn’t compatible with the launch, I purchased others - but nevertheless I cannot connect the launch. I have onboard bluetooth 4.1 w/ BLE (Atheros QCA61x4), so I tried that first without success. Then I disabled the QCA61x4, and tried the following dongles:

ASUS USB-BT400 (BCM20702A0)
ORICO BTA-403 (CSR8510 A10)
and I had an older TrendNet TBW-108UB but being this is a dual wifi / bt transmitter I didn’t expect much, and sure enough it didn’t work

I read all threads here, and all instructions on buttplug io and scriptplayer @ github. States a few times NOT to install the bluetooth dongle drivers, so I did not, I simply plugged it in and windows assigned generic drivers, and gave a try to connect, without success. Windows 10 @ 17763.316.

Do I need another brand of dongle? Or am I doing something wrong?

Thanks very much in advance ty-


#2

FL sent me a new unit. This time, I didn’t bother trying to upgrade firmware, or connect to feelConnect app. It connects no problem via buttplug and/or scriptplayer and/or syncydink, using my onboard Qualcomm Atheros QCA61x4 bluetooth 4.1.

I flashed the old unit with 1.3 f/w that I got from a link qdot posted. Not sure if my new unit is older firmware, but works perfectly now.


#3

Ok, first off, wow, I had no idea charging the device possibly kicked it out of bootloader mode! I’ll have to try this myself. That could be huge for helping people who’ve got bricked devices if this works out.

Also interesting that it works with your Atheros now too, that’s the chipset we have the most problems with and that I usually don’t recommend people use, but if it’s working for you, great!

The adapter I usually recommend is a BCM20702A0, so not sure why your original one didn’t work, but it sounds like you’re mostly sorted for the moment anyway. Do let us know if you have any other issues!


#4

so to be clear:

while it was bricked flashing red/blue, it wouldn’t connect or show up on anything - mac/android/ios/linux/win10. After messing with it for a while the launch battery started to die, so I plugged it in to charge. But, I had to move it to another wall socket - so I disconnected the power from the wall (didn’t press any buttons). When I did that, I noticed the power LED was solid green, and the bluetooth lights were completely off (black). I decided to try and pair the launch in that state, with my macbook pro - to try and connect it to the web firmware utility you guys made. Sure enough, it took longer than usual, but it did connect in that state, and I managed to flash the 1.3 firmware. But still, this unit doesn’t connect to scriptplayer nor buttplug server nor syncydink - but it does connect to feelConnect / my android Pixel now. Kinda at a loss on that one.

Got a new launch off of warranty - took it out of the box, charged it, and tried to immediately connect to script player on my win 10. Worked straight away. So I dunno what happened… but that’s my version of events. Hope that helps.