Lovense Domi Detection Issues


#1

Hi All,

I found an interesting issue with the Lovense Domi when trying to get the device detected in the Buttplug Websocket Server. When I set the websocket server to “Trace,” I can see that the server is seeing the device. The main issue is that when I’m using the Buttplug Playground to test the device, it never actually shows up in the list of devices.

Here is a snippet where I can see the websocket server can see the device:

2018-02-24 09:36:08.5551|TRACE|ButtplugJsonMessageParser|Message successfully parsed as StartScanning type
2018-02-24 09:36:08.5551|TRACE|ButtplugServer|Got Message 16 of type StartScanning to send
2018-02-24 09:36:08.5551|DEBUG|DeviceManager|Got StartScanning Message
2018-02-24 09:36:08.5551|INFO|UWPBluetoothManager|Starting BLE Scanning
2018-02-24 09:36:08.5681|INFO|XInputGamepadManager|XInputGamepadManager start scanning
2018-02-24 09:36:08.5681|INFO|ETSerialManager|Starting Scanning Serial Ports for ErosTek Devices
2018-02-24 09:36:08.5681|TRACE|ButtplugJsonMessageParser|Message serialized to: [{“Ok”:{“Id”:16}}]
2018-02-24 09:36:08.6751|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{“Ping”:{“Id”:17}}]
2018-02-24 09:36:08.6751|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-02-24 09:36:08.6751|TRACE|ButtplugServer|Got Message 17 of type Ping to send
2018-02-24 09:36:08.6751|TRACE|ButtplugJsonMessageParser|Message serialized to: [{“Ok”:{“Id”:17}}]
2018-02-24 09:36:08.8065|TRACE|UWPBluetoothManager|BLE device found: LVS-Domi39
2018-02-24 09:36:08.8065|TRACE|UWPBluetoothManager|BLE device found:
2018-02-24 09:36:09.0314|TRACE|UWPBluetoothManager|BLE device found: LVS-Domi39
2018-02-24 09:36:09.0314|TRACE|UWPBluetoothManager|BLE device found:
2018-02-24 09:36:09.1748|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{“Ping”:{“Id”:18}}]
2018-02-24 09:36:09.1748|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-02-24 09:36:09.1748|TRACE|ButtplugServer|Got Message 18 of type Ping to send
2018-02-24 09:36:09.1768|TRACE|ButtplugJsonMessageParser|Message serialized to: [{“Ok”:{“Id”:18}}]
2018-02-24 09:36:09.3829|TRACE|UWPBluetoothManager|BLE device found:
2018-02-24 09:36:09.3829|TRACE|UWPBluetoothManager|BLE device found:
2018-02-24 09:36:09.3829|TRACE|UWPBluetoothManager|BLE device found: LVS-Domi39
2018-02-24 09:36:09.3829|TRACE|UWPBluetoothManager|BLE device found:
2018-02-24 09:36:09.6196|TRACE|UWPBluetoothManager|BLE device found: LVS-Domi39
2018-02-24 09:36:09.6196|TRACE|UWPBluetoothManager|BLE device found:

I also have a Launch and a Vorze; both devices have no issues with showing up in the list of devices for the playground. I am currently running off a laptop with W10 Build 1709 and Bluetooth 4.1. Any suggestions would be greatly appreciated.


#2

The problem is that we found out about that name for the Domi like, 2 days after we released 0.2.0. :slight_smile:

The code is there to support it, we just need to put out a new release. We’re hopefully doing that any day now, but until then, if you’d like to live on the bleeding edge, here’s the latest installer from our dev branch, which should work with the Domi you have: https://ci.appveyor.com/api/buildjobs/uivi1ei00kcjdfog/artifacts/Buttplug-Release-0.2.0.608-installer.exe


#3

Thanks for your fix, qdot! I just tried the branch you posted and that has addressed the issue. I was actually reading the one post about someone having issues with the Lovense Edge, before I made this post, and was curious if the problem with the Domi stemmed from the same issue (Lovense constantly changing the name and UUID of devices).


#4

Great, glad it worked for you!

Yup, that’s one of our most common issues with toy support. We’ve got a project lined up to make that somewhat easier to deal with than “recompile the whole damn thing and make a new release”, I just need to actually stop writing documentation and making videos and actually get the code done. Ah, the balance of small open source projects. :slight_smile:


#5

I had a similar issue where my Domi was not being found (Win10, webserver). Turns out the removing Lovense dongle from device manager checking the option to remove drivers fixed it, never had trouble finding it again. Might be good advice for anyone reading this far down this forum post.


#6

Hello.
I’m currently facing this problem with a new Domi.

2018-05-05 15:39:33.1157|TRACE|UWPBluetoothManager|BLE device found: LVS-Domi40
2018-05-05 15:39:33.1197|TRACE|UWPBluetoothManager|BLE device found:

How do i get to a fix for this issue?


#7

That’s a device name that showed up after our last release, so you’ll need to use one of our newer test releases. Try this one:

https://ci.appveyor.com/api/buildjobs/3rvaabimvshbmdq2/artifacts/Buttplug-Release-0.2.1.650-installer.exe


#8

And it’s working like a charm.
Thank you very much for the fast reply.


#9

I’m definitely still getting this issue on the most up to date server and a brand new Domi. It vibrates on the test in the tutorial but is not showing up in Playground.

Device name is now LVS-Domi41, so is it another “they’ve changed the name, the little buggers” sort of deal?


#10

We shouldn’t have issues with name changing anymore, as we implemented a way to find all devices just using the LVS- prefix.

Are you using the windows server or the in-browser connections in tutorial and playground?


#11

Was in browser last time I tried.


#12

On what OS/browser did you try that?


#13

Running Windows 10, Chrome and Firefox. Both on most recent versions.


#14

Ok, so you’re running the Windows Buttplug Server app on Windows 10, and connecting the browser to it in the Tutorial and Playground?


#15

Yes. It all seems to go ok but nothing shows up in Playground. I’m happy to admit I may just be being dense, but as far as I can tell I’m following the instructions.

Further detail will have to come after a) I sleep and b) I’m back at the computer to try it again