Lovense Edge support?


#1

I have a launch working fine with the websocket server, but the Edge isn’t showing up in a scan. Is this lovense device not supported? Can I help in any way to have it show up? Thanks.

I have both a BCM920703 Bluetooth 4.1 adapter and the Lovense one. I currently use the B4 one with my Launch. It pairs and works fine with the Launch, but it isn’t finding the Edge in either Playground or Scriptplayer.

edit: Also, I am getting a “Registry keys not set for UWP bluetooth API security. This may cause Bluetooth devices to not be seen.” Google has not provided any helpful fix on this.

edit2: It seems I was using my Vive bluetooth (which the Launch works on it seems), I also have a BT 4.0 adapter which it works on, but not the Edge. I have tried it paired and unpaired with windows.


#2

Ok, to fix the UWP bluetooth API security issue, you need to reinstall the Buttplug App Suite software (the thing you download from https://github.com/metafetish/buttplug-csharp/releases). Try that and let me know if it clears up that error, as that may be what’s causing it to not work with the Edge.

The Edge should work, I have one and have tested it successfully with our software on windows/mac/linux/android.


#3

ok thanks I’ll check it out.


#4

The Bluetooth adapter that comes with the Lovense Max and Nora is BT2 only. My Edge didn’t come with a Bluetooth adapter: it’s BT4 only.

On Windows 10, I have found that unbinding BT devices from the system not as easy as it should be. If Windows is bound to the device, it’s unlikely that the Buttplug server will be able to see it.


#5

Hmm, I’m using https://www.amazon.com/Plugable-Bluetooth-Adapter-Raspberry-Compatible/dp/B009ZIILLI and it’s still not working. In the logs it says it sees it…

2018-01-08 00:31:11.2039|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":7}}]
2018-01-08 00:31:11.3968|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:11.3968|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:11.3968|TRACE|UWPBluetoothManager|BLE device found: HTC BS 7E81B8
2018-01-08 00:31:11.3968|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:11.4978|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{"Ping":{"Id":8}}]
2018-01-08 00:31:11.4978|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-01-08 00:31:11.4978|TRACE|ButtplugServer|Got Message 8 of type Ping to send
2018-01-08 00:31:11.4978|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":8}}]
2018-01-08 00:31:11.7458|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:11.7458|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:11.8721|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:11.8751|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:11.9977|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{"Ping":{"Id":9}}]
2018-01-08 00:31:11.9977|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-01-08 00:31:11.9977|TRACE|ButtplugServer|Got Message 9 of type Ping to send
2018-01-08 00:31:11.9977|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":9}}]
2018-01-08 00:31:12.1066|TRACE|UWPBluetoothManager|BLE device found: HTC BS 7E81B8
2018-01-08 00:31:12.1066|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.2159|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:12.2189|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.2189|TRACE|UWPBluetoothManager|BLE device found: Launch
2018-01-08 00:31:12.2189|DEBUG|UWPBluetoothDeviceFactory|Found Launch for Buttplug.Server.Bluetooth.Devices.FleshlightLaunchBluetoothInfo
2018-01-08 00:31:12.2189|DEBUG|UWPBluetoothDeviceFactory|No advertised services?
2018-01-08 00:31:12.2189|DEBUG|UWPBluetoothManager|Found BLE factory: UWPBluetoothDeviceFactory
2018-01-08 00:31:12.3511|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:12.3511|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.4973|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{"Ping":{"Id":10}}]
2018-01-08 00:31:12.4973|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-01-08 00:31:12.4973|TRACE|ButtplugServer|Got Message 10 of type Ping to send
2018-01-08 00:31:12.4973|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":10}}]
2018-01-08 00:31:12.7039|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:12.7039|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.8241|TRACE|UWPBluetoothManager|BLE device found: HTC BS 7E81B8
2018-01-08 00:31:12.8241|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.9300|TRACE|UWPBluetoothManager|BLE device found: HTC BS 7E81B8
2018-01-08 00:31:12.9300|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:12.9975|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{"Ping":{"Id":11}}]
2018-01-08 00:31:12.9975|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-01-08 00:31:12.9975|TRACE|ButtplugServer|Got Message 11 of type Ping to send
2018-01-08 00:31:12.9975|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":11}}]
2018-01-08 00:31:13.0527|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:13.0527|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:13.1788|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:13.1788|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:13.3149|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:13.3149|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:13.4072|TRACE|UWPBluetoothManager|BLE device found: LVS-Edge37
2018-01-08 00:31:13.4072|TRACE|UWPBluetoothManager|BLE device found: 
2018-01-08 00:31:13.4970|TRACE|ButtplugJsonMessageParser|Got JSON Message: [{"Ping":{"Id":12}}]
2018-01-08 00:31:13.4970|TRACE|ButtplugJsonMessageParser|Message successfully parsed as Ping type
2018-01-08 00:31:13.4970|TRACE|ButtplugServer|Got Message 12 of type Ping to send
2018-01-08 00:31:13.4970|TRACE|ButtplugJsonMessageParser|Message serialized to: [{"Ok":{"Id":12}}]

The HTC stuff is for the Vive.


#6

Lovense keep chaining the names and UUIDs on their devices, so we have to keep re-adding support each time we get reports of the change.

The update to support the “LVS-Edge37” variant has been committed, but not released yet. If you want to test the build before the official release, you can install the CI build from here: https://ci.appveyor.com/project/qdot/buttplug-csharp/build/0.1.3.565/job/tmytwkj6sdi99qvo/artifacts


#7

That worked, thanks.