Lovense max and hush not being discovered


#1

Hi there,I am trying to use my lovense toys with buttplug but nothing seems to work,i tried your tutorial on websocket server ,everything is connecting but when it comes to scanning the devices,they never show,i have tried on both windows 10 pc and laptop running windows 10 version 1703,please help


#2

the fact that they are not being discovered i can’t get them to work with any buttplug software


#3

Ok, what kind of bluetooth adapter are you using?


#4

Well I am using the one I got from lovense,which came with the toys and I also tried the default Bluetooth adapter of my HP elite book

Thanks


#5

Ah, ok. The lovense adapter is bluetooth 2, and to use bluetooth on windows, you need a bluetooth 4 adapter. We recommend https://www.amazon.com/Plugable-Bluetooth-Adapter-Raspberry-Compatible/dp/B009ZIILLI


#6

Oh OK,but the max connects to the Bluetooth adapter and so does everything else, when trying to connect to your software it does not pic up,and what about with the default HP Bluetooth adapter on my laptop?lovense max also connects and works with it,only doesn’t pick up with your software


#7

The Lovense Nora and Max both support a legacy Bluetooth 2 mode, which is what Windows will be showing you.

Buttplug’s Lovense interface uses their Bluetooth LE interface, which works across all of their devices, but requires a Bluetooth 4 adapter.

Incedently, if you connect to the Max on its Bluetooth 2 interface from the Windows Bluetooth interface it will prevent Buttplug from seeing the device’s Bluetooth 4 device regardless of whether or not your Bluetooth adapter supports BLE.