Stuff connected through initface can't see emulated x360 controlelrs

Hey, i used to play around with buttplug 2.3 and dirt cheap controllers i could hack apart without going broke, and it worked well with an emulator called motionjoy (v7.1 offline version, and denied all internet access for good measure). So far practically any program i tried got fooled by it with working force feedback/rumble, including unity with an xinput plugin, glowpie, autohotkey…

Recently i wanted to try some of the new things, but they needed the new interface desktop, which just doesn’t want to cooperate with me: after running all setup steps, updates, certs, installed net framework versions, i still couldn’t connect with it to the playground (running firefox, no log on the server, “Error: Cannot connect to Intiface Desktop” message form the playground), nor syncydink (“websocket connection failed”, though i could connect and it did detect my emulated controller using buttplug 2.3, so i assume its just not updated), i could connect to the tutorial client, but when after the first connection i try to find devices it disconnects, then going back, connecting again it works, but trying to find devices again, it sees nothing (sadly i cant test it with any other device, just the emulators).

trying other programs:



They behaved much the same: with bp2.3 they crashed on connect (something like package format not handled), and connected to initface but couldn’t find any device.
Finally, since i’m overdue to my reformat, i tried some other emulators, from which xoutput using ViGEm framework did what i was looking for: actually adding an xbox360 controller to my devices, but nothing saw that either, hence why i think i might be missing something else, but i am at wits end. Any ideas?

Thanks in advance and thanks in general. This whole project is something i was looking for for a long time and i love seeing it keep expanding.