Trouble connecting via internet (timeout)


#1

Apologies if this is a duplicate or I missed something in setup; I’ve spent the last hour or so going down rabbit holes to dead ends.

I got it all working for local just fine, but being able to use something like buttplug for control over web is more or less the make-or-break for me getting a Launch or Onyx so that I can have more intimacy in my long-distance relationship.

I’m using the C# install with almost entirely default options, and I’ve forwarded port 12345. As stated, my local machine connects through buttplug.world just fine (using network ip or localhost), but my other laptop (on WiFi) and my phone (on data/WiFi, tested both) fail to connect. The error on their side is the typical SSL/websocket one, but the host console shows no errors. Attempting to go to https://<host_machine_ip>:12345/buttplug gives me a timeout. The host IP isn’t listed in the websocket addresses either–is this not supported by the default install?


#2

The first thing to check is that the localhost only option in the Buttplug Server GUI is unchecked, otherwise it’ll only allow connections on the local machine.

If that doesn’t solve it, let us know and we’ll see how best to help.


#3

First off, thanks for the reply!

Nope, I have that unchecked and SSL on for the moment, though I didn’t see any difference with it off. My server gui is showing my local/network IP and localhost as the only two addresses.


#4

Next thing to check is whether your other devices can connect to the server on the same network. I’m pretty sure you already stated you’ve tested that and it didn’t work, which could indicate that either the windows firewall or some other firewall software may be blocking the connections.


#5

Oh, just remembered that if you’re testing with playground (which is served over HTTPS), your browser’s might reject the unencrypted websocket connection. I recommend enabling SSL and testing by just browsing to server over HTTPS (you should get a certificate warning, that once skipped will give you a blank page)


#6

I always forget about that damn firewall…seems like that’s the only thing I missed. I can get there from my other machines now, even off-network. Thanks!


#7

No worries: glad to help.